aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-31 17:50:13 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-08-08 11:55:36 +0200
commit4ecf37c1899349e6ef7ac08813ebb52fc80b2677 (patch)
tree88d6b940fc8e6f296ac2a93dfab32bba1711418d /src/CMakeLists.txt
parent330edf6a1ec91fa5a9829d6450fa4fff0b91c693 (diff)
afb-trace: Add tracing features to API monitor
This api allows to receive events when particular actions are reached. At the moment, tracing is bound to the API monitor and can trace anything. In the future, this will not be the case and the API monitor will only allow to trace requests of its session. The tracing of all will be available for supervision only. Change-Id: I880852612c2f77ff5329496b16c75fe602db4090 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2789846..3cf7547c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,6 +56,7 @@ ADD_LIBRARY(afb-lib STATIC
afb-session.c
afb-stub-ws.c
afb-svc.c
+ afb-trace.c
afb-websock.c
afb-ws-client.c
afb-ws-json1.c