aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-07-20 17:57:59 +0200
committerJose Bollo <jose.bollo@iot.bzh>2018-07-25 15:12:48 +0200
commitf96bbb49cc9bcd81693300191cf7a01b879fd83d (patch)
tree0d50513ecaab432ce2a4fbd73175363b49545b7e /src/CMakeLists.txt
parentfe9601cbf6bbebe9464bfbde2efd0ec278b3e243 (diff)
afb-config: Rewrite the config as JSON object
Despite its poor performance, this changes is good at the end because: - it allows to put config in files - it removes dirty code to translate to JSON - it removes dirty code to dump the config - it unifies code for scanning hook's flag's names - it improves unity of naming between option's names and JSON's names Change-Id: I2487c8746d78a0cff80505a12b9fa60e40da9951 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 421866da..ba6ba77e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -45,6 +45,7 @@ SET(AFB_LIB_SOURCES
afb-export.c
afb-fdev.c
afb-hook.c
+ afb-hook-flags.c
afb-hreq.c
afb-hsrv.c
afb-hswitch.c