aboutsummaryrefslogtreecommitdiffstats
path: root/src/devtools/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-20 15:22:40 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-20 15:22:40 +0100
commit45c8372c2b4137691a38c2a04f4a5759a110f2f7 (patch)
treed3cf5f1b3711ab7ee79f624ba7c6ed28ff1f148a /src/devtools/CMakeLists.txt
parente1b255b4c6486b0d2df5cd8b2aad8b817876ddf2 (diff)
CMAKE: refactor optionseel_4.99.3eel/4.99.34.99.3
The option ALLOW_NO_BINDER is removed and the option ONLY_DEVTOOLS is introduced. Change-Id: Ia19eb977ee25a3871582605028fdef75e552363f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/devtools/CMakeLists.txt')
-rw-r--r--src/devtools/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/devtools/CMakeLists.txt b/src/devtools/CMakeLists.txt
new file mode 100644
index 00000000..b1d63825
--- /dev/null
+++ b/src/devtools/CMakeLists.txt
@@ -0,0 +1,30 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+ADD_EXECUTABLE(afb-genskel genskel.c)
+ADD_EXECUTABLE(afb-exprefs exprefs.c)
+ADD_EXECUTABLE(afb-json2c json2c.c)
+
+TARGET_LINK_LIBRARIES(afb-genskel ${link_libraries})
+TARGET_LINK_LIBRARIES(afb-exprefs ${link_libraries})
+TARGET_LINK_LIBRARIES(afb-json2c ${link_libraries})
+
+INSTALL(TARGETS afb-genskel RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+INSTALL(TARGETS afb-exprefs RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+INSTALL(TARGETS afb-json2c RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+