summaryrefslogtreecommitdiffstats
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2018-11-22 09:03:33 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-11-22 17:39:50 +0100
commitbc247d4c9e16e548c84466d8975529568e7c395d (patch)
tree757edd27e14a08b7122062febd01e34d425f41fd /src/tests/CMakeLists.txt
parent153a7c9c44ac84f32a0869ed14e4f08563e6d97c (diff)
globset: Introduce globset for event handlingguppy_6.99.1guppy/6.99.16.99.1
It optimises the event handling that was slow. It also fix few bugs: - at most one event handler is called now - the handler call has the most specific pattern Change-Id: Ic13a0258b5743579ab15e0e953ec62206d982850 Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
index b516a9db..b0ddbdbf 100644
--- a/src/tests/CMakeLists.txt
+++ b/src/tests/CMakeLists.txt
@@ -25,6 +25,7 @@ if(check_FOUND)
add_subdirectory(apiset)
add_subdirectory(apiv3)
add_subdirectory(wrap-json)
+ add_subdirectory(globset)
else(check_FOUND)
MESSAGE(WARNING "check not found! no test!")
endif(check_FOUND)