aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/apiset/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-05-03 15:08:10 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-05-03 15:19:51 +0200
commit4da9c713d091872f8e18cf096d2c5f616183d3b4 (patch)
treea8d2cdec54ef8a1c3f91b85582cd1729dbada3e3 /src/tests/apiset/CMakeLists.txt
parent5d57096e3682083c20b2a0fd3ddb9ef75148a94e (diff)
afb-export: Fix requirement on multiple apis
The test 'test-apiv3' was failing because the required api list "albert armel" wasn't splitted but set as-is. At the same time, test suite is improved. Bug-AGL: SPEC-1130 Bug-AGL: SPEC-2377 Change-Id: Ia4ab23bf666b5b4b1db3e1da2654d9387c2c01e5 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/tests/apiset/CMakeLists.txt')
-rw-r--r--src/tests/apiset/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/tests/apiset/CMakeLists.txt b/src/tests/apiset/CMakeLists.txt
index 62ca5e44..59b51319 100644
--- a/src/tests/apiset/CMakeLists.txt
+++ b/src/tests/apiset/CMakeLists.txt
@@ -16,6 +16,10 @@
# limitations under the License.
###########################################################################
+add_definitions(
+ -DAGL_DEVEL=$<BOOL:${AGL_DEVEL}>
+ -DWITH_AFB_HOOK=$<BOOL:${WITH_AFB_HOOK}>
+)
add_executable(test-apiset test-apiset.c)
target_include_directories(test-apiset PRIVATE ../..)
target_link_libraries(test-apiset afb-lib ${link_libraries})