aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/globset/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2018-11-22 09:03:33 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-11-22 17:39:50 +0100
commitbc247d4c9e16e548c84466d8975529568e7c395d (patch)
tree757edd27e14a08b7122062febd01e34d425f41fd /src/tests/globset/CMakeLists.txt
parent153a7c9c44ac84f32a0869ed14e4f08563e6d97c (diff)
globset: Introduce globset for event handlingguppy_6.99.1guppy/6.99.16.99.1
It optimises the event handling that was slow. It also fix few bugs: - at most one event handler is called now - the handler call has the most specific pattern Change-Id: Ic13a0258b5743579ab15e0e953ec62206d982850 Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/tests/globset/CMakeLists.txt')
-rw-r--r--src/tests/globset/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/tests/globset/CMakeLists.txt b/src/tests/globset/CMakeLists.txt
new file mode 100644
index 00000000..6bc9e600
--- /dev/null
+++ b/src/tests/globset/CMakeLists.txt
@@ -0,0 +1,23 @@
+###########################################################################
+# Copyright (C) 2017, 2018 "IoT.bzh"
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+add_executable(test-globset test-globset.c)
+target_include_directories(test-globset PRIVATE ../..)
+target_link_libraries(test-globset afb-lib ${link_libraries})
+add_test(NAME globset COMMAND test-globset)
+