aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/u16id/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2019-11-19 13:43:06 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2019-11-29 12:48:17 +0100
commit0fd887b7ab896e47b2f7ffe78f41738f3824a962 (patch)
treec8e1e39c1969f65387543bec49d460a4787f2624 /src/tests/u16id/CMakeLists.txt
parent5ac7bb0d9d16260d2235820e97ab47943ffc307b (diff)
u16id: Add maps for identifiers id of 16 bits
These maps will shortly be used by protocol to handle tokens/sessions/events. Bug-AGL: SPEC-2968 Change-Id: Iadef7d6e01c8ef021516749524b10ccc1abec340 Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/tests/u16id/CMakeLists.txt')
-rw-r--r--src/tests/u16id/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/tests/u16id/CMakeLists.txt b/src/tests/u16id/CMakeLists.txt
new file mode 100644
index 00000000..4141611e
--- /dev/null
+++ b/src/tests/u16id/CMakeLists.txt
@@ -0,0 +1,23 @@
+###########################################################################
+# Copyright (C) 2017-2019 "IoT.bzh"
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+add_executable(test-u16id test-u16id.c)
+target_include_directories(test-u16id PRIVATE ../..)
+target_link_libraries(test-u16id afb-lib ${link_libraries})
+add_test(NAME u16id COMMAND test-u16id)
+