summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8d2d2a..eb2d2d12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,6 +112,20 @@ SET(link_libraries
SET(binding_install_dir ${CMAKE_INSTALL_FULL_LIBDIR}/afb)
+###########################################################################
+# activates the monitoring by default
+set(INCLUDE_MONITORING ON CACHE BOOL "Activates installation of monitoring")
+if(INCLUDE_MONITORING)
+ add_definitions(-DWITH_MONITORING_OTPION)
+ INSTALL(DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}/test/monitoring
+ DESTINATION
+ ${binding_install_dir}
+ )
+endif()
+
+###########################################################################
+
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(bindings)