summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d7e1d07..1037b43e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,11 @@ INCLUDE(GNUInstallDirs)
INCLUDE(CTest)
###########################################################################
+# possible settings
+set(AGL_DEVEL OFF CACHE BOOL "Activates developping features")
+set(INCLUDE_MONITORING OFF CACHE BOOL "Activates installation of monitoring")
+
+###########################################################################
link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
@@ -82,6 +87,10 @@ PKG_CHECK_MODULES(openssl REQUIRED openssl)
PKG_CHECK_MODULES(uuid REQUIRED uuid)
PKG_CHECK_MODULES(cynara cynara-client)
+IF(AGL_DEVEL)
+ ADD_DEFINITIONS(-DAGL_DEVEL)
+endif()
+
IF(cynara_FOUND)
ADD_DEFINITIONS(-DBACKEND_PERMISSION_IS_CYNARA)
ENDIF(cynara_FOUND)