summaryrefslogtreecommitdiffstats
path: root/bindings/tutorial/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/tutorial/CMakeLists.txt')
-rw-r--r--bindings/tutorial/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/bindings/tutorial/CMakeLists.txt b/bindings/tutorial/CMakeLists.txt
new file mode 100644
index 00000000..844e2dfb
--- /dev/null
+++ b/bindings/tutorial/CMakeLists.txt
@@ -0,0 +1,32 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+#INCLUDE_DIRECTORIES(${include_dirs})
+
+MACRO(tuto num)
+ ADD_LIBRARY(tuto-${num} MODULE tuto-${num}.c)
+ SET_TARGET_PROPERTIES(tuto-${num} PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
+ )
+ TARGET_LINK_LIBRARIES(tuto-${num} ${link_libraries})
+ENDMACRO(tuto)
+
+tuto(1)
+tuto(2)