aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/audio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/audio/CMakeLists.txt')
-rw-r--r--plugins/audio/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/audio/CMakeLists.txt b/plugins/audio/CMakeLists.txt
index 7fa1f75f..ee858b4c 100644
--- a/plugins/audio/CMakeLists.txt
+++ b/plugins/audio/CMakeLists.txt
@@ -1,6 +1,10 @@
IF(alsa_FOUND)
- ADD_LIBRARY(audio-api MODULE audio-api.c audio-alsa.c)
+ IF(pulseaudio_FOUND)
+ SET(pulse_sources audio-pulse.c)
+ ENDIF(pulseaudio_FOUND)
+
+ ADD_LIBRARY(audio-api MODULE audio-api.c audio-alsa.c ${pulse_sources})
SET_TARGET_PROPERTIES(audio-api PROPERTIES PREFIX "")
TARGET_LINK_LIBRARIES(audio-api ${link_libraries})
INCLUDE_DIRECTORIES(${include_dirs})