summaryrefslogtreecommitdiffstats
path: root/plugins/audio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/audio/CMakeLists.txt')
-rw-r--r--plugins/audio/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/plugins/audio/CMakeLists.txt b/plugins/audio/CMakeLists.txt
new file mode 100644
index 00000000..b5adc643
--- /dev/null
+++ b/plugins/audio/CMakeLists.txt
@@ -0,0 +1,10 @@
+IF(alsa_FOUND)
+
+ INCLUDE_DIRECTORIES(${include_dirs})
+
+ ADD_LIBRARY(audio-api MODULE audio-api.c audio-alsa.c)
+ SET_TARGET_PROPERTIES(audio-api PROPERTIES PREFIX "")
+ INSTALL(TARGETS audio-api
+ LIBRARY DESTINATION ${plugin_install_dir})
+
+ENDIF(alsa_FOUND)