summaryrefslogtreecommitdiffstats
path: root/plugins/radio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/radio/CMakeLists.txt')
-rw-r--r--plugins/radio/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/radio/CMakeLists.txt b/plugins/radio/CMakeLists.txt
index c7c85411..04d0fa21 100644
--- a/plugins/radio/CMakeLists.txt
+++ b/plugins/radio/CMakeLists.txt
@@ -1,9 +1,9 @@
IF(librtlsdr_FOUND)
- INCLUDE_DIRECTORIES(${include_dirs})
-
ADD_LIBRARY(radio-api MODULE radio-api.c radio-rtlsdr.c)
SET_TARGET_PROPERTIES(radio-api PROPERTIES PREFIX "")
+ TARGET_LINK_LIBRARIES(radio-api ${link_libraries})
+ INCLUDE_DIRECTORIES(${include_dirs})
INSTALL(TARGETS radio-api
LIBRARY DESTINATION ${plugin_install_dir})