summaryrefslogtreecommitdiffstats
path: root/plugins/radio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/radio/CMakeLists.txt')
-rw-r--r--plugins/radio/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/plugins/radio/CMakeLists.txt b/plugins/radio/CMakeLists.txt
new file mode 100644
index 00000000..c7c85411
--- /dev/null
+++ b/plugins/radio/CMakeLists.txt
@@ -0,0 +1,10 @@
+IF(librtlsdr_FOUND)
+
+ INCLUDE_DIRECTORIES(${include_dirs})
+
+ ADD_LIBRARY(radio-api MODULE radio-api.c radio-rtlsdr.c)
+ SET_TARGET_PROPERTIES(radio-api PROPERTIES PREFIX "")
+ INSTALL(TARGETS radio-api
+ LIBRARY DESTINATION ${plugin_install_dir})
+
+ENDIF(librtlsdr_FOUND)