summaryrefslogtreecommitdiffstats
path: root/plugins/samples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/samples/CMakeLists.txt')
-rw-r--r--plugins/samples/CMakeLists.txt49
1 files changed, 37 insertions, 12 deletions
diff --git a/plugins/samples/CMakeLists.txt b/plugins/samples/CMakeLists.txt
index 9f600c82..eb6e0112 100644
--- a/plugins/samples/CMakeLists.txt
+++ b/plugins/samples/CMakeLists.txt
@@ -1,33 +1,57 @@
INCLUDE_DIRECTORIES(${include_dirs})
-ADD_LIBRARY(helloWorld-api MODULE HelloWorld.c)
-SET_TARGET_PROPERTIES(helloWorld-api PROPERTIES
+##################################################
+# AuthLogin
+##################################################
+ADD_LIBRARY(authLogin MODULE AuthLogin.c)
+SET_TARGET_PROPERTIES(authLogin PROPERTIES
PREFIX ""
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
)
-TARGET_LINK_LIBRARIES(helloWorld-api ${link_libraries})
-INSTALL(TARGETS helloWorld-api
+TARGET_LINK_LIBRARIES(authLogin ${link_libraries})
+INSTALL(TARGETS authLogin
LIBRARY DESTINATION ${plugin_install_dir})
-ADD_LIBRARY(samplePost-api MODULE SamplePost.c)
-SET_TARGET_PROPERTIES(samplePost-api PROPERTIES
+##################################################
+# DemoContext
+##################################################
+ADD_LIBRARY(demoContext MODULE DemoContext.c)
+SET_TARGET_PROPERTIES(demoContext PROPERTIES
PREFIX ""
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
)
-TARGET_LINK_LIBRARIES(samplePost-api ${link_libraries})
-INSTALL(TARGETS samplePost-api
+TARGET_LINK_LIBRARIES(demoContext ${link_libraries})
+INSTALL(TARGETS demoContext
LIBRARY DESTINATION ${plugin_install_dir})
-ADD_LIBRARY(clientCtx-api MODULE ClientCtx.c)
-SET_TARGET_PROPERTIES(clientCtx-api PROPERTIES
+##################################################
+# DemoPost
+##################################################
+ADD_LIBRARY(demoPost MODULE DemoPost.c)
+SET_TARGET_PROPERTIES(demoPost PROPERTIES
PREFIX ""
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
)
-TARGET_LINK_LIBRARIES(clientCtx-api ${link_libraries})
-INSTALL(TARGETS clientCtx-api
+TARGET_LINK_LIBRARIES(demoPost ${link_libraries})
+INSTALL(TARGETS demoPost
LIBRARY DESTINATION ${plugin_install_dir})
+##################################################
+# HelloWorld
+##################################################
+ADD_LIBRARY(helloWorld MODULE HelloWorld.c)
+SET_TARGET_PROPERTIES(helloWorld PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
+)
+TARGET_LINK_LIBRARIES(helloWorld ${link_libraries})
+INSTALL(TARGETS helloWorld
+ LIBRARY DESTINATION ${plugin_install_dir})
+
+##################################################
+# tic-tac-toe
+##################################################
ADD_LIBRARY(tic-tac-toe MODULE tic-tac-toe.c)
SET_TARGET_PROPERTIES(tic-tac-toe PROPERTIES
PREFIX ""
@@ -36,3 +60,4 @@ SET_TARGET_PROPERTIES(tic-tac-toe PROPERTIES
TARGET_LINK_LIBRARIES(tic-tac-toe ${link_libraries})
INSTALL(TARGETS tic-tac-toe
LIBRARY DESTINATION ${plugin_install_dir})
+