summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 68beea00..67e3abce 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,5 @@
-ADD_LIBRARY(src OBJECT
+ADD_LIBRARY(afb-lib OBJECT
afb-api-dbus.c
afb-api-so.c
afb-apis.c
@@ -16,11 +16,21 @@ ADD_LIBRARY(src OBJECT
afb-ws-json1.c
afb-ws.c
afb-wsj1.c
- main.c
session.c
verbose.c
websock.c
)
+
+INCLUDE_DIRECTORIES(${include_dirs})
+
+ADD_EXECUTABLE(afb-daemon $<TARGET_OBJECTS:afb-lib> main.c)
+INCLUDE_DIRECTORIES(${include_dirs})
+TARGET_LINK_LIBRARIES(afb-daemon ${link_libraries})
+
+ADD_EXECUTABLE(afb-client-demo $<TARGET_OBJECTS:afb-lib> afb-client-demo.c)
INCLUDE_DIRECTORIES(${include_dirs})
+TARGET_LINK_LIBRARIES(afb-client-demo ${link_libraries})
+INSTALL(TARGETS afb-daemon
+ RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})