summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 00000000..434332b4
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,9 @@
+SET(AFB-DAEMON_HEADERS local-def.h proto-def.h)
+SET(AFB-DAEMON_SOURCES main.c config.c session.c http-svc.c afbs-api.c dbus-api.c rest-api.c alsa-api.c)
+ADD_EXECUTABLE(afb-daemon ${AFB-DAEMON_SOURCES})
+
+include_directories(${include_dirs})
+target_link_libraries(afb-daemon ${link_libraries})
+
+INSTALL(TARGETS afb-daemon
+ RUNTIME DESTINATION bin)