summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bc5fd4f0..707b2e09 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,20 +1,22 @@
ADD_LIBRARY(src OBJECT
- main.c
- session.c
+ afb-api-dbus.c
+ afb-api-so.c
+ afb-apis.c
+ afb-common.c
+ afb-context.c
+ afb-hreq.c
afb-hsrv.c
afb-hswitch.c
- afb-apis.c
- afb-api-so.c
afb-method.c
- afb-hreq.c
+ afb-msg-json.c
afb-websock.c
- afb-ws.c
afb-ws-json.c
- afb-msg-json.c
- afb-common.c
- websock.c
+ afb-ws.c
+ main.c
+ session.c
verbose.c
+ websock.c
)
INCLUDE_DIRECTORIES(${include_dirs})