summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-12-13 16:47:45 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2019-12-13 17:24:21 +0100
commitb65d4e0061d77718ee6c04c6cd1d41f6940b5a03 (patch)
tree0e90fc2aac0f774fb3dee42e0daeecfee1e0b4a7 /CMakeLists.txt
parent653562e1449c935f087d2d8265081eeac1cd73b4 (diff)
Ensure home and workir to widget of scope-platformicefish_8.99.3icefish/8.99.38.99.3
The widget requesting the permission to run at platform scope: urn:AGL:permission::partner:scope-platform should be able to record data and state. This change provides a default place to achieve it. Bug-AGL: SPEC-2998 Change-Id: I148a670d3e08e36603ebd318b533ea1e1a695750 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c83e59d..4e28c8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,7 @@ set(systemd_units_root "${CMAKE_INSTALL_FULL_LIBDIR}/systemd" CACHE STRING
set(wgtpkg_trusted_cert_dir "${afm_confdir}/certs" CACHE STRING "Path to internal certificates")
set(afm_platform_rundir "/run/platform" CACHE STRING "Path to location of platform runtime sockets")
set(afm_users_rundir "/run/user" CACHE STRING "Path to location of users runtime sockets")
+set(afm_scope_platform_dir "/var/scope-platform" CACHE STRING "Path to home of scope-platform apps")
if(USE_SIMULATION)
set(SIMULATE_SECMGR ON)