summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-11-08 12:56:05 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2016-11-08 12:56:05 +0100
commit4cd8d99ab22ab339d54203bf977648af71d91499 (patch)
tree2677a3afe572809d4ec55aa12f83385936c017af /CMakeLists.txt
parent4a1409460a7c0a5d26fe10b5f84368b3cb8b8b5a (diff)
Adds a pkgconfig file for directories
Change-Id: Icbd3c7bc52232ca0fec6f4c69694bfaa0b64ef8e Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2e62b2..0fe6bb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@ include(GNUInstallDirs)
set(PROJECT_NAME "AFM Main")
set(PROJECT_PRETTY_NAME "Application Framework Main")
-set(PROJECT_DESCRIPTION "Secured Application framework")
+set(PROJECT_DESCRIPTION "Secured Application framework for Automotive Grade Linux")
set(PROJECT_VERSION "1.0")
set(USE_LIBZIP ON CACHE BOOL "should try to use libzip?")
@@ -67,4 +67,14 @@ add_subdirectory(conf)
add_subdirectory(scripts)
add_subdirectory(certs)
+############################################################
+# installs the pkgconfig files
+
+CONFIGURE_FILE(afm-main.pc.in afm-main.pc @ONLY)
+INSTALL(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/afm-main.pc
+ DESTINATION
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ )
+