summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-12-23 15:31:09 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2015-12-23 16:17:24 +0100
commit9549e8c28032c2d1fb578c43f1b340d1457b3c70 (patch)
tree1e6e1681c05375f83f45de35f57f43a66afaf502 /CMakeLists.txt
parentdacfe1eeef622d7db8824392db9b6be877ee6a8c (diff)
zip/unzip: don't only rely on libzip
Change-Id: I2bd2cf0c9447a47fdb56661c15e852e52e9dcba7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b76abb3..2e6995c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,18 +16,20 @@
# limitations under the License.
###########################################################################
-cmake_minimum_required(VERSION 2.8)
+project(afm-main C)
-project("afm-main" LANGUAGES "C")
+cmake_minimum_required(VERSION 2.8)
include(GNUInstallDirs)
macro(setc name value)
if(NOT DEFINED ${name})
- set(${name} "${value}")
+ set(${name} ${value})
endif(NOT DEFINED ${name})
endmacro(setc)
+setc(USE_LIBZIP 1)
+
setc(afm_name "aglfwk")
setc(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}")
setc(afm_datadir "${CMAKE_INSTALL_FULL_DATADIR}/${afm_name}")