summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-03-14 10:26:49 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-03-17 13:01:40 +0100
commitfcc925c4a6d7bc82106f6c8da13b1a58a7b23115 (patch)
tree0432ba71b4449325f54caedfebfe8511f1e7a278 /CMakeLists.txt
parentde02ff4734caf96658f40a9e352245f5046a183a (diff)
wgtpkg-install: creates the systemd units
Change-Id: Ia3cdcb76a9f7b3bda77a9d9fcb38dfd85eb85804 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83e0c39..45ac19c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ set(afm_prefix "urn:AGL:" CACHE STRING "Prefix for uniform resource
set(afm_prefix_binding "${afm_prefix}binding:" CACHE STRING "URN for bindings")
set(afm_user_appdir "app-data" CACHE STRING "User subdirectory for applications")
set(afm_user_appdir_label "User::App-Shared" CACHE STRING "Smack label of the user subdirectory for applications")
+set(systemd_units_root "${CMAKE_INSTALL_FULL_LIBDIR}/systemd" CACHE STRING "Place where unit files are to be set")
set(wgtpkg_trusted_cert_dir "${afm_confdir}/certs" CACHE STRING "Path to internal certificates")
if(USE_SIMULATION)
@@ -62,6 +63,7 @@ add_definitions(
-DFWK_LAUNCH_CONF="${afm_confdir}/afm-launch.conf"
-DFWK_UNIT_CONF="${afm_confdir}/afm-unit.conf"
-DFWK_USER_APP_DIR_LABEL="${afm_user_appdir_label}"
+ -DSYSTEMD_UNITS_ROOT="${systemd_units_root}"
)
add_subdirectory(src)