summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-04-30 10:00:35 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-04-30 10:00:35 +0200
commitd0d4dcd0460e3ef93c20661c603dd24353a0d127 (patch)
tree73021ed967850e569b8176ca2cdac1b08833230a /CMakeLists.txt
parentb4ca569c08a233114fb77106a8b4aa34d47ab54c (diff)
Allow setting of libexec location
The location of the framework binding could not be tuned but is fixed. The default location is good but it is important to be able to tune that location. This at least has the good effect that the location is set at one point in the build system instead of at multiple points as today. Bug-AGL: SPEC-2367 Change-Id: Ib06fdff56d1828eacd0d1f82c2e1308d0b36fa5e Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76753b0..3d1ce1b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,7 @@ set(SIMULATE_SMACK OFF CACHE BOOL "if set, the smack environment is simulated")
set(afm_name "afm" CACHE STRING "Name for application framework user")
set(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}" CACHE STRING "Directory for configuration files")
set(afm_datadir "${CMAKE_INSTALL_FULL_DATADIR}/${afm_name}" CACHE STRING "Root directory for installions")
+set(afm_libexecdir "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${afm_name}" CACHE STRING "Directory for installing internal binaries")
set(afm_appdir "${afm_datadir}/applications" CACHE STRING "Directory for installing applications")
set(afm_icondir "${afm_datadir}/icons" CACHE STRING "Directory for installing icons")
set(afm_prefix "urn:AGL:" CACHE STRING "Prefix for uniform resource name")