summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-12-08 13:16:11 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2015-12-08 13:16:11 +0100
commit7fc1ab01c2309d3078e3d66cfff05bf27fdad26f (patch)
treefc8b19c5387e5b921c2b8e9806097896f72e5ee1 /Makefile.am
parent82a1641c0570e6548649dac932853959854cd706 (diff)
Support for elements of config.xml
This add some elements intended to be used later when handling data coming from config.xml of widgets. Change-Id: I1df9eb158d5c37578c9c7a8caa9eb8f85527ca4b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 02a724c..d9ffed5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,11 @@ COMMONSRCS = \
wgtpkg-xmlsec.c \
wgtpkg-zip.c
+WGTSRCS = \
+ wgt-config-xml.c \
+ wgt-locales.c \
+ wgt-strings.c
+
AM_CFLAGS = -Wall -Wno-pointer-sign
AM_CFLAGS += -ffunction-sections -fdata-sections
AM_CFLAGS += ${ZIP_CFLAGS} ${XML2_CFLAGS} ${OPENSSL_CFLAGS} ${XMLSEC_CFLAGS}
@@ -18,7 +23,7 @@ AM_LDFLAGS = -Wl,--gc-sections
LDADD = ${ZIP_LIBS} ${XML2_LIBS} ${OPENSSL_LIBS} ${XMLSEC_LIBS}
-wgtpkg_install_SOURCES = wgtpkg-install.c ${COMMONSRCS}
+wgtpkg_install_SOURCES = wgtpkg-install.c ${WGTSRCS} ${COMMONSRCS}
wgtpkg_sign_SOURCES = wgtpkg-sign.c ${COMMONSRCS}