summaryrefslogtreecommitdiffstats
path: root/conf/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-10-12 10:58:40 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-24 17:44:57 +0100
commit1a67d1b401cbf132687b5aaea52ca7875edaa1f9 (patch)
tree083ad7c8f235bfe255ca00ad47ccccef19f62f05 /conf/CMakeLists.txt
parentdd87fc32c026b4fba9b13ab52f032e3b403b04bf (diff)
Remove afm-system-daemon
Change-Id: I1e6c0488b7183724a65fcc06fd3cf6909e0efd53 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/CMakeLists.txt')
-rw-r--r--conf/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/conf/CMakeLists.txt b/conf/CMakeLists.txt
index 2188dc0..ad2090d 100644
--- a/conf/CMakeLists.txt
+++ b/conf/CMakeLists.txt
@@ -21,16 +21,16 @@ cmake_minimum_required(VERSION 2.8)
configure_file(afm-unit.conf.in afm-unit.conf)
configure_file(afm-unit-debug.conf.in afm-unit-debug.conf)
configure_file(afm-system-daemon.service.in afm-system-daemon.service)
+configure_file(afm-system-daemon.socket.in afm-system-daemon.socket)
configure_file(afm-user-daemon.service.in afm-user-daemon.service)
if(NOT USE_SDK)
- set(SYSCONFDIR_DBUS_SYSTEM ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/system.d CACHE STRING "Path to dbus system configuration files")
set(SYSCONFDIR_DBUS_USER ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/session.d CACHE STRING "Path to dbus session configuration files")
set(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system CACHE STRING "Path to systemd system unit files")
set(UNITDIR_USER ${CMAKE_INSTALL_LIBDIR}/systemd/user CACHE STRING "Path to systemd system unit files")
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-system-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_SYSTEM})
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-system-daemon.service DESTINATION ${UNITDIR_SYSTEM})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-system-daemon.socket DESTINATION ${UNITDIR_SYSTEM})
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-user-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_USER})
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-user-daemon.service DESTINATION ${UNITDIR_USER})
install(DIRECTORY DESTINATION ${afm_confdir}/unit.env.d)