summaryrefslogtreecommitdiffstats
path: root/conf/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-12-29 17:40:21 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2015-12-29 17:40:21 +0100
commitffad58b4a2a45613101f4dca75cf6cde33e74cb3 (patch)
tree8e6a7438e3636b809c6c998e13a0ade3d8093054 /conf/CMakeLists.txt
parentdf95c86712d96754a4d660e9ddf98bdbad746cf4 (diff)
packages and install configuration files
Change-Id: I8a0d4c42d7fe02eabc06c91af9c488bb8235df4a
Diffstat (limited to 'conf/CMakeLists.txt')
-rw-r--r--conf/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/conf/CMakeLists.txt b/conf/CMakeLists.txt
new file mode 100644
index 0000000..67f60a7
--- /dev/null
+++ b/conf/CMakeLists.txt
@@ -0,0 +1,30 @@
+###########################################################################
+# Copyright 2015 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+cmake_minimum_required(VERSION 2.8)
+
+setc(SYSCONFDIR_DBUS_SYSTEM ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/system.d)
+setc(SYSCONFDIR_DBUS_USER ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/user.d)
+setc(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system)
+setc(UNITDIR_USER ${CMAKE_INSTALL_LIBDIR}/systemd/user)
+
+install(FILES afm-system-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_SYSTEM})
+install(FILES afm-system-daemon.service DESTINATION ${UNITDIR_SYSTEM})
+install(FILES afm-user-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_USER})
+install(FILES afm-user-daemon.service DESTINATION ${UNITDIR_USER})
+