summaryrefslogtreecommitdiffstats
path: root/conf/system/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-23 16:14:56 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-24 17:44:58 +0100
commiteb2e468e14028935907dbe057edc3826516b3af7 (patch)
treebe3c2579d3733f62b8ada4f4c4c372e5f28fc2d2 /conf/system/CMakeLists.txt
parent7998a472352c0272a90c66ab45c4c2758cd6040a (diff)
Add a PAM config file
Change-Id: I27f726cd3cec7c0e499086c5ac3de1a736ef108c Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/system/CMakeLists.txt')
-rw-r--r--conf/system/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/conf/system/CMakeLists.txt b/conf/system/CMakeLists.txt
index f0e4c6a..d0605eb 100644
--- a/conf/system/CMakeLists.txt
+++ b/conf/system/CMakeLists.txt
@@ -23,9 +23,11 @@ configure_file(afm-system-daemon.socket.in afm-system-daemon.socket)
if(NOT USE_SDK)
set(SYSCONFDIR_DBUS_SYSTEM ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/system.d CACHE STRING "Path to dbus system configuration files")
- set(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system CACHE STRING "Path to systemd system unit files")
+ set(SYSCONFDIR_PAMD ${CMAKE_INSTALL_SYSCONFDIR}/pam.d CACHE STRING "Path to pam configuration files")
+ set(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system CACHE STRING "Path to systemd system unit files")
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-system-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_SYSTEM})
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-user-session.pamd DESTINATION ${SYSCONFDIR_PAMD} RENAME afm-user-session)
install(
FILES
${CMAKE_CURRENT_BINARY_DIR}/afm-system-daemon.service