aboutsummaryrefslogtreecommitdiffstats
path: root/conf/system/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-06-06 12:11:14 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-06-14 11:17:53 +0200
commit533d5a1a51a07f2f92e508d113cb49d373e1bad8 (patch)
treeebfaa7db1f265b5c62e36fb0094cd34903d6dfe8 /conf/system/CMakeLists.txt
parent77bd42075de481ae89f6a5b2bc8a79bf967d95cd (diff)
Fix synchronisation of user setup
The user setup takes care of populating correctly the directory /run/user/UID with needed items BEFORE user services start. Bug-AGL: SPEC-1015 Change-Id: I6f942d73bf241d593c960dbf3bc6a038f1746fe0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/system/CMakeLists.txt')
-rw-r--r--conf/system/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/conf/system/CMakeLists.txt b/conf/system/CMakeLists.txt
index a49d37f..3cabd0c 100644
--- a/conf/system/CMakeLists.txt
+++ b/conf/system/CMakeLists.txt
@@ -51,6 +51,12 @@ if(NOT USE_SDK)
${UNITDIR_SYSTEM}
)
install(
+ DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}/user-runtime-dir@.service.wants
+ DESTINATION
+ ${UNITDIR_SYSTEM}
+ )
+ install(
PROGRAMS
${CMAKE_CURRENT_BINARY_DIR}/afm-user-setup.sh
${CMAKE_CURRENT_BINARY_DIR}/afm-system-setup.sh