summaryrefslogtreecommitdiffstats
path: root/conf/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-03-28 11:36:05 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2019-03-28 11:40:26 +0100
commit20bf07791d69cd25b73139379ccb8947c5f1b2f7 (patch)
tree9b785db9268f21303cb7a7e227a598cadc0e8763 /conf/unit/CMakeLists.txt
parent3476b426fb3443ff909f8d607934e59601c7d508 (diff)
afm-unit.conf: Add widget specific environment
This change allow to set environment specific to a widget in ${afm_confdir}/widget.env.d/ID/* files where ID is the ID of the widget. Setting specific environment for a given widget was not possible (except in devel/debug) before. Change-Id: I8ef9349fda9adb8eecf330ce97cc7ebcd21bf399 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/unit/CMakeLists.txt')
-rw-r--r--conf/unit/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/conf/unit/CMakeLists.txt b/conf/unit/CMakeLists.txt
index 6e64400..1d11e11 100644
--- a/conf/unit/CMakeLists.txt
+++ b/conf/unit/CMakeLists.txt
@@ -26,6 +26,7 @@ endif()
if(NOT USE_SDK)
install(DIRECTORY DESTINATION ${afm_confdir}/unit.env.d)
+ install(DIRECTORY DESTINATION ${afm_confdir}/widget.env.d)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-unit.conf DESTINATION ${afm_confdir})
endif()