aboutsummaryrefslogtreecommitdiffstats
path: root/conf/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-23 15:44:24 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-24 17:44:58 +0100
commit7998a472352c0272a90c66ab45c4c2758cd6040a (patch)
treede3fb484fa2bca0850354f611551b049083d1420 /conf/unit/CMakeLists.txt
parent633ebe33015554a14b773053188e2faba0faff04 (diff)
Rework on systemd start of user sessions
Change-Id: Iad46596435eebdc5c521b572fd8320b52a61d197 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/unit/CMakeLists.txt')
-rw-r--r--conf/unit/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/conf/unit/CMakeLists.txt b/conf/unit/CMakeLists.txt
new file mode 100644
index 0000000..69f201d
--- /dev/null
+++ b/conf/unit/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+cmake_minimum_required(VERSION 2.8)
+
+if(AGL_DEVEL)
+ configure_file(afm-unit-debug.conf.in afm-unit.conf)
+else()
+ configure_file(afm-unit.conf.in afm-unit.conf)
+endif()
+
+if(NOT USE_SDK)
+ install(DIRECTORY DESTINATION ${afm_confdir}/unit.env.d)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-unit.conf DESTINATION ${afm_confdir})
+endif()
+