summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-12-09 14:35:04 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2015-12-09 14:35:04 +0100
commitbf7b5918fcc07713a29b9ca32f766b65b15a4ec2 (patch)
treea4ad318995f3213cee35a2065fc3c4911e2012dc /configure.ac
parent0270b7281b783cbea5c1f0ebb4440d2be1bd79fa (diff)
refactoring sources
Change-Id: Id6d52eee86b706958972e9b345ec0d4d1e488146 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5cf0a62..ea099b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,8 +5,8 @@ AC_PREREQ([2.69])
AC_INIT([wgtpkg], [1.0], [wgtpkg@iot.bzh])
AM_INIT_AUTOMAKE
#AM_INIT_AUTOMAKE([-Wall -Wno-pointer-sign])
-AC_CONFIG_SRCDIR([wgtpkg-files.c])
-AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_SRCDIR([src/wgtpkg-files.c])
+AC_CONFIG_HEADERS([src/config.h])
# Checks for programs.
#AC_PROG_CXX
@@ -37,6 +37,8 @@ AC_TYPE_SSIZE_T
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([atexit memmove mkdir realpath rmdir stpcpy strrchr strtoul])
+AC_CHECK_FUNCS([strcasecmp strdup strndup])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
AC_OUTPUT