summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-01-26 19:05:28 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-01-26 19:05:28 +0100
commita85c80f25325c69579f3b6c6df847d631e68d0b5 (patch)
treeef55a8c8c75a0ff064fe42d77bbba0547ab9bf9f /src/CMakeLists.txt
parenta08368b93b263aa52df3eeb4c90669ae6da7cd6e (diff)
Add utils-file and provide json-c
This is an intermediate commit providing new features for common utils. Change-Id: Ide92167d8e4e5013ddadd718c02071ea837938e3 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6b2b280..f126346 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -41,7 +41,7 @@ set(CMAKE_C_FLAGS_CCOV "-g -O2 --coverage")
include(FindPkgConfig)
-pkg_check_modules(EXTRAS REQUIRED libxml-2.0 openssl xmlsec1 xmlsec1-openssl)
+pkg_check_modules(EXTRAS REQUIRED libxml-2.0 openssl xmlsec1 xmlsec1-openssl json-c)
add_compile_options(${EXTRAS_CFLAGS})
include_directories(${EXTRAS_INCLUDE_DIRS})
link_libraries(${EXTRAS_LIBRARIES})
@@ -95,6 +95,8 @@ add_library(wgtpkg STATIC
add_library(utils STATIC
utils-dir.c
+ utils-file.c
+ utils-json.c
verbose.c
)
@@ -131,7 +133,7 @@ install(TARGETS wgtpkg-sign wgtpkg-pack wgtpkg-info wgtpkg-installer DESTINATION
###########################################################################
# the targeted
-pkg_check_modules(EXTRA2 json-c libsystemd)
+pkg_check_modules(EXTRA2 libsystemd)
if(EXTRA2_FOUND)
add_compile_options(${EXTRA2_CFLAGS})
include_directories(${EXTRA2_INCLUDE_DIRS})
@@ -139,7 +141,6 @@ if(EXTRA2_FOUND)
add_library(utils2 STATIC
utils-jbus.c
- utils-json.c
)
add_library(afm STATIC