summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-01-22 10:07:42 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-01-22 10:07:42 +0100
commit2db7c770244f97c8674b6e9c78ed50319b38fea3 (patch)
tree4c3710d0f45e54d12187090f9abad8fb142b7a91 /src/CMakeLists.txt
parentef97895c1a00bddb7436c928e27f767496cfea5c (diff)
afm-user-session: Create afm-user-session
This new executable is the simplest user session manager: it waits the signal SIGTERM to stop and thus release the session. Change-Id: I557f27386c19ca3e2b28b21dd6a58918e9ca47be Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9921660..8f98c0d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -175,6 +175,9 @@ if(libsystemd_FOUND AND AFB_FOUND)
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/afm-binding.export-map"
)
install(TARGETS afm-binding LIBRARY DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/afm)
+
+ add_executable(afm-user-session afm-user-session.c)
+ install(TARGETS afm-user-session DESTINATION ${CMAKE_INSTALL_BINDIR})
else()
MESSAGE(STATUS "Not creating daemons")
endif()