summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-12-29 15:08:15 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2015-12-29 15:13:46 +0100
commit36a5034839183d1c49b63e4cbd955004bf46a8b3 (patch)
tree1d0ffe483fd49f75e36daf25bc8b7e311f9c7de1 /src/CMakeLists.txt
parent6b8b90ae60a9f1deb0d45c92fbd0da697462b781 (diff)
manages simulation of security-manager
Change-Id: Ia465bab3ae99e95daa7afd5bd22a98bea1bfef17
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 89d4d51..c47e632 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,7 +46,14 @@ endif(USE_LIBZIP)
###########################################################################
-include_directories(simulation)
+if(USE_SIMULATION)
+ include_directories(simulation)
+else(USE_SIMULATION)
+ pkg_check_modules(SECMGR REQUIRED security-manager)
+ add_compile_options(${SECMGR_CFLAGS})
+ include_directories(${SECMGR_INCLUDE_DIRS})
+ link_libraries(${SECMGR_LIBRARIES})
+endif(USE_SIMULATION)
###########################################################################