summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-10-11 17:33:27 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-24 17:44:57 +0100
commitf551ac4966543b360e3458a61615626d71f55a6e (patch)
tree7ce227ac1ca160d2ebb8cc46f63bd5e0b215b6cb /src/CMakeLists.txt
parentecb483c282d48a6236c2aafd3beaa355e5a75e73 (diff)
afm-user-daemon: rewriten to use direct API
The coming version of afm-system-daemon will no more use DBUS but will provide a websocket API. Change-Id: I5ff0488ff5ec5b2b9a193d869efe8a9c5896516f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 782e154..0214c12 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -61,7 +61,7 @@ add_compile_options(${libsystemd_CFLAGS})
include_directories(${libsystemd_INCLUDE_DIRS})
link_libraries(${libsystemd_LIBRARIES})
-pkg_check_modules(AFB REQUIRED afb-daemon>=4.0)
+pkg_check_modules(AFB REQUIRED afb-daemon>=4.99 libafbwsc>=4.99)
###########################################################################
@@ -155,7 +155,7 @@ MESSAGE(STATUS "Creating daemons")
add_library(jbus STATIC utils-jbus.c)
add_executable(afm-user-daemon afm-user-daemon.c)
-target_link_libraries(afm-user-daemon afm secwrp wgt utils jbus)
+target_link_libraries(afm-user-daemon jbus utils afbwsc)
install(TARGETS afm-user-daemon DESTINATION ${CMAKE_INSTALL_BINDIR})
add_executable(afm-system-daemon afm-system-daemon.c)