summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-01-04 15:09:36 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2016-01-04 15:44:27 +0100
commitcda8f0470953975c45c66b8f3b7249f36f064d78 (patch)
treed125c68406e56693770e24018331e5f963b16230 /src/CMakeLists.txt
parent07c512dad1762f3791cc796a3014b43a0211345b (diff)
wgtpkg-zip: use PATH for retriving programs
When using yocto, the directive 'find_program' of cmake returns a path that matches the host path when builing, not the path of the file on the target. Using the standard algorithm for seeking programs using PATH should solve the problem. Change-Id: I426a88fe044a1d1b3a72124da17ca8a188caad9c Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c47e632..fb55e60 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -39,9 +39,7 @@ if(USE_LIBZIP)
link_libraries(${LIBZIP_LIBRARIES})
add_definitions(-DUSE_LIBZIP=1)
else(USE_LIBZIP)
- find_program(PATH_TO_ZIP zip)
- find_program(PATH_TO_UNZIP unzip)
- add_definitions(-DUSE_LIBZIP=0 -DPATH_TO_ZIP="${PATH_TO_ZIP}" -DPATH_TO_UNZIP="${PATH_TO_UNZIP}")
+ add_definitions(-DUSE_LIBZIP=0)
endif(USE_LIBZIP)
###########################################################################