summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2511af..0591847 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,19 +32,18 @@ SET(PROJECT_NAME "AFM Main")
SET(PROJECT_PRETTY_NAME "Application Framework Main")
SET(PROJECT_DESCRIPTION "Secured Application framework")
SET(PROJECT_VERSION "1.0")
-SET(PROJECT_URL "https://github.com/iotbzh/afm-main")
setc(USE_LIBZIP 1)
setc(USE_SIMULATION 1)
-setc(afm_name "aglfwk")
-setc(afm_confdir "${CMAKE_INSTALL_SYSCONFDIR}/${afm_name}")
-setc(afm_datadir "${CMAKE_INSTALL_DATADIR}/${afm_name}")
+setc(afm_name "afm")
+setc(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}")
+setc(afm_datadir "${CMAKE_INSTALL_FULL_DATADIR}/${afm_name}")
setc(afm_appdir "${afm_datadir}/applications")
setc(afm_icondir "${afm_datadir}/icons")
setc(afm_prefix "urn:agl:")
setc(afm_prefix_permission "${afm_prefix}perm:")
-setc(afm_prefix_plugin "${afm_prefix}plugin:")
+setc(afm_prefix_binding "${afm_prefix}binding:")
setc(afm_user_appdir "app-data")
setc(wgtpkg_trusted_cert_dir "${afm_confdir}/certs")
@@ -54,7 +53,7 @@ endmacro(defstr)
defstr(FWK_CONFIG_DIR "${afm_confdir}")
defstr(FWK_PREFIX_PERMISSION "${afm_prefix_permission}")
-defstr(FWK_PREFIX_PLUGIN "${afm_prefix_plugin}")
+defstr(FWK_PREFIX_BINDING "${afm_prefix_binding}")
defstr(FWK_ICON_DIR "${afm_icondir}")
defstr(FWK_APP_DIR "${afm_appdir}")
defstr(FWK_USER_APP_DIR "${afm_user_appdir}")