summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b76abb3..2e6995c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,18 +16,20 @@
# limitations under the License.
###########################################################################
-cmake_minimum_required(VERSION 2.8)
+project(afm-main C)
-project("afm-main" LANGUAGES "C")
+cmake_minimum_required(VERSION 2.8)
include(GNUInstallDirs)
macro(setc name value)
if(NOT DEFINED ${name})
- set(${name} "${value}")
+ set(${name} ${value})
endif(NOT DEFINED ${name})
endmacro(setc)
+setc(USE_LIBZIP 1)
+
setc(afm_name "aglfwk")
setc(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}")
setc(afm_datadir "${CMAKE_INSTALL_FULL_DATADIR}/${afm_name}")