aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 89d4d51..c47e632 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,7 +46,14 @@ endif(USE_LIBZIP)
###########################################################################
-include_directories(simulation)
+if(USE_SIMULATION)
+ include_directories(simulation)
+else(USE_SIMULATION)
+ pkg_check_modules(SECMGR REQUIRED security-manager)
+ add_compile_options(${SECMGR_CFLAGS})
+ include_directories(${SECMGR_INCLUDE_DIRS})
+ link_libraries(${SECMGR_LIBRARIES})
+endif(USE_SIMULATION)
###########################################################################