aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f126346..c38dd07 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -86,14 +86,17 @@ add_library(wgtpkg STATIC
wgtpkg-digsig.c
wgtpkg-files.c
wgtpkg-install.c
+ wgtpkg-mustach.c
wgtpkg-permissions.c
wgtpkg-uninstall.c
+ wgtpkg-unit.c
wgtpkg-workdir.c
wgtpkg-xmlsec.c
wgtpkg-zip.c
)
add_library(utils STATIC
+ mustach.c
utils-dir.c
utils-file.c
utils-json.c
@@ -104,6 +107,7 @@ add_library(wgt STATIC
wgt-config.c
wgt-info.c
wgt-strings.c
+ wgt-json.c
wgt.c
)
@@ -189,3 +193,9 @@ if(EXTRA2_FOUND)
endif()
endif(EXTRA2_FOUND)
+
+###########################################################################
+# the tests
+
+add_subdirectory(tests)
+