summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-12-12 10:39:31 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2018-12-14 09:15:07 +0000
commitc631646116197507f59008bc4a4560c74756b342 (patch)
tree04e9f003e15837a43d27ee4e04d4ca7aeefc3583 /CMakeLists.txt
parentc815f74207220e5e571fece7cbad00b7a39ae8c9 (diff)
Install docs and sample files in a separate dir
Separate the samples files to be installed in the system doc dir which is: - /usr/share/doc Updating the documentation according to the new path to samples. Change-Id: Ib1958fb87d517ad84abddf3ec71102f7ecf877f5 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9ca3f1..2fd3bbc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,14 +18,14 @@
cmake_minimum_required(VERSION 3.5)
+project(CMakeAfbTemplates)
+
# compute the default install directory
include(GNUInstallDirs)
get_filename_component(CMAKE_DIR ${CMAKE_ROOT} NAME)
-set(DEFAULT_INSTALL_DIR ${CMAKE_INSTALL_DATADIR}/${CMAKE_DIR}/Modules)
-
-# set the install directory, allowing its overwriting
-set(INSTALL_DIR ${DEFAULT_INSTALL_DIR} CACHE PATH "Installation directory")
+set(INSTALL_DIR ${CMAKE_INSTALL_DATADIR}/${CMAKE_DIR}/Modules)
# install the module
INSTALL(FILES CMakeAfbTemplates.cmake DESTINATION ${INSTALL_DIR})
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/src/ DESTINATION ${INSTALL_DIR}/CMakeAfbTemplates)
+INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/docs/ DESTINATION ${CMAKE_INSTALL_DOCDIR})