summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-11-05 10:38:16 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2018-11-06 20:30:35 +0100
commit5f06de040287a5df88d21367da9e8725d8585ba1 (patch)
treebba4fb8aa6474b451f4f6f7af327c46ed6e181ae /CMakeLists.txt
parentdcdff18c4f09406ca1ec522fbde3f6f7342d8423 (diff)
Adding packaging files
Change-Id: I70d30588c59e6a0d3c451c74fc6cc565b5eea167 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8449464..cd1eb5d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,10 +16,9 @@
# limitations under the License.
###########################################################################
-cmake_minimum_required(VERSION 3.6)
+cmake_minimum_required(VERSION 3.5)
include(GNUInstallDirs)
INSTALL(FILES CMakeAfbTemplates.cmake DESTINATION ${CMAKE_ROOT}/Modules)
-INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/ DESTINATION ${CMAKE_ROOT}/Modules/CMakeAfbTemplates
- REGEX "(CMakeAfbTemplates.cmake|gendocs.sh|book.json|CMakeLists.txt|docs|build|.*\/\.git.*)" EXCLUDE)
+INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/src/ DESTINATION ${CMAKE_ROOT}/Modules/CMakeAfbTemplates)