summaryrefslogtreecommitdiffstats
path: root/templates/html5/app/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-12 09:59:36 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-10-15 18:22:20 +0200
commite4799748deb2449b19e3ae95b53b891827ef607e (patch)
tree59e6e8d75ded7b2d9bf001c626a67287d3a85c15 /templates/html5/app/CMakeLists.txt
parent1435f4c7f73a51e2a672287424dd0464726a0943 (diff)
Adding comments as documentation for each target.
Change-Id: Ia4d73bd4c2cd3be882998c45fca2fa3da8bae971 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'templates/html5/app/CMakeLists.txt')
-rw-r--r--templates/html5/app/CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/templates/html5/app/CMakeLists.txt b/templates/html5/app/CMakeLists.txt
index b41c0da..ae5f9aa 100644
--- a/templates/html5/app/CMakeLists.txt
+++ b/templates/html5/app/CMakeLists.txt
@@ -16,7 +16,9 @@
# limitations under the License.
###########################################################################
-# Add target to project dependency list
+# Project target list
+# --------------------
+# Add target to project dependency list.
PROJECT_TARGET_ADD(html5-app)
# Define project Targets
@@ -29,7 +31,19 @@ PROJECT_TARGET_ADD(html5-app)
add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)
- # Binder exposes a unique public entry point
+ # Targets properties
+ # ------------------
+ # Target properties will be used to build package tree that will be
+ # built using project_package_build.
+ # OUTPUT_NAME: Depends what is the name of your output file, it is
+ # mandatory to specify which is its name with target the property
+ # OUTPUT_NAME for your target. If file name is same of your target then
+ # use variable ${TARGET_NAME}.
+ # LABELS: Choose between "BINDING", "HTDOCS", "EXECUTABLE" depending of
+ # the type of your target.
+ # PREFIX: This prefix will be added on the output file name specify with
+ # OUTPUT_NAME. By default, there isn't PREFIX on target except on
+ # library target with is "lib".
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
LABELS "HTDOCS"
OUTPUT_NAME dist.prod)