summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-01-28 16:14:59 -0500
committerScott Murray <scott.murray@konsulko.com>2022-01-28 16:19:28 -0500
commit5d094ec17f0f60489efe9df6c113be62f80b4c2a (patch)
tree266b3471abb9520afaca36fe0af491e8a72ec98b /meson.build
parent4da886055d7cdc659858eec3a45e14f52fcfa643 (diff)
GLib based interface library for ConnMan, factored out of the agl-service-network binding code. See README.md for build and usage notes and the mapping of the new source files to those in the binding if that is for some reason required. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I13c0982c790353c6e48f21bb8c4953a676840dbb
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..661255b
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,16 @@
+project('connman-glib', 'c', license : 'Apache-2.0')
+
+systemd_dep = dependency('systemd', version : '>=222')
+glib_deps = [dependency('glib-2.0'), dependency('gio-2.0'), dependency('gobject-2.0'), dependency('gio-unix-2.0')]
+
+inc = include_directories('include')
+
+subdir('include')
+subdir('src')
+
+pkg_mod = import('pkgconfig')
+pkg_mod.generate(libraries : lib,
+ version : '1.0',
+ name : 'libconnman-glib',
+ filebase : 'connman-glib',
+ description : 'GLib helper library for using ConnMan.')