summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-10-03 12:34:13 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-10-04 13:43:10 +0200
commitd4a2c432763b033acf7c94ee7e121aca5a3a4f10 (patch)
treee972628992c5f8a49ba3704c10ab9b1058c4c1b9 /CMakeLists.txt
parentbf0edaecd3cbf088992ba4bae20d761cceeb1742 (diff)
Improve library split parts
In prevision of further developments (like plugins) the server is splitted in two parts: the server program itself and the core library. The client library is also splitted in two parts: the compatibility part and the real client part. Change-Id: Iaee93298d52eb825ad9aed5d2b3e74c2975b5950 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 15 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c96027b..5879513 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,24 +16,25 @@
# limitations under the License.
###########################################################################
-CMAKE_MINIMUM_REQUIRED(VERSION 3.0)
+cmake_minimum_required(VERSION 3.0)
-PROJECT(cynara C)
+project(cynara C)
-SET(PROJECT_NAME "Cynara")
-SET(PROJECT_PRETTY_NAME "Permission database")
-SET(PROJECT_DESCRIPTION "Secured permission database for applications")
-SET(PROJECT_VERSION "1.99.99")
+set(PROJECT_NAME "Cynara")
+set(PROJECT_PRETTY_NAME "Permission database")
+set(PROJECT_DESCRIPTION "Secured permission database for applications")
+set(PROJECT_VERSION "1.99.99")
set(PROJECT_URL "https://gerrit.automotivelinux.org/gerrit/gitweb?p=src/cynara.git;a=summary")
-INCLUDE(FindPkgConfig)
-INCLUDE(CheckIncludeFiles)
-INCLUDE(CheckLibraryExists)
-INCLUDE(GNUInstallDirs)
+include(FindPkgConfig)
+include(CheckIncludeFiles)
+include(CheckLibraryExists)
+include(GNUInstallDirs)
+include(CTest)
+
if(NOT CMAKE_INSTALL_FULL_RUNSTATEDIR)
- set(CMAKE_INSTALL_FULL_RUNSTATEDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/run")
+ set(CMAKE_INSTALL_FULL_RUNSTATEDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/run")
endif()
-INCLUDE(CTest)
###########################################################################
# possible settings
@@ -76,8 +77,8 @@ set(CMAKE_C_FLAGS_CCOV "-g -O2 --coverage")
###########################################################################
if(SYSTEMD)
- PKG_CHECK_MODULES(libsystemd REQUIRED libsystemd>=222)
- add_subdirectory(systemd)
+ PKG_CHECK_MODULES(libsystemd REQUIRED libsystemd>=222)
+ add_subdirectory(systemd)
endif()
add_subdirectory(include)