summaryrefslogtreecommitdiffstats
path: root/pkgconfig/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-10-03 12:34:13 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-10-04 13:43:10 +0200
commitd4a2c432763b033acf7c94ee7e121aca5a3a4f10 (patch)
treee972628992c5f8a49ba3704c10ab9b1058c4c1b9 /pkgconfig/CMakeLists.txt
parentbf0edaecd3cbf088992ba4bae20d761cceeb1742 (diff)
Improve library split parts
In prevision of further developments (like plugins) the server is splitted in two parts: the server program itself and the core library. The client library is also splitted in two parts: the compatibility part and the real client part. Change-Id: Iaee93298d52eb825ad9aed5d2b3e74c2975b5950 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'pkgconfig/CMakeLists.txt')
-rw-r--r--pkgconfig/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgconfig/CMakeLists.txt b/pkgconfig/CMakeLists.txt
index f32ad70..6875ab6 100644
--- a/pkgconfig/CMakeLists.txt
+++ b/pkgconfig/CMakeLists.txt
@@ -21,6 +21,11 @@ configure_file(cynara.pc.in cynara.pc @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cynara.pc
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+configure_file(cynara-compat.pc.in cynara-compat.pc @ONLY)
+
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cynara-compat.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
foreach(item cynara-admin.pc
cynara-agent.pc
cynara-client-async.pc
@@ -34,7 +39,7 @@ foreach(item cynara-admin.pc
cynara-monitor.pc
cynara-plugin.pc
cynara-session.pc)
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/link.pc
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/link-to-cynara-compat.pc
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
RENAME ${item})
endforeach(item)