aboutsummaryrefslogtreecommitdiffstats
path: root/pkgconfig/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-10-03 14:33:21 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-10-04 16:02:32 +0200
commitb5bd40e1e68b739307e20e19d2164c5b370846df (patch)
tree91d05e9d740e7e0413509ab7a563b3ce14444b62 /pkgconfig/CMakeLists.txt
parentd4a2c432763b033acf7c94ee7e121aca5a3a4f10 (diff)
Isolate compatibility with old cynara
The compatibility items of the old cynara librarie are separated and isolated. The option WITH_CYNARA_COMPAT activates it or not. Change-Id: Iba77c97d8df31f5f515b57411487943192451ac6 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'pkgconfig/CMakeLists.txt')
-rw-r--r--pkgconfig/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/pkgconfig/CMakeLists.txt b/pkgconfig/CMakeLists.txt
index 6875ab6..14c05d5 100644
--- a/pkgconfig/CMakeLists.txt
+++ b/pkgconfig/CMakeLists.txt
@@ -20,27 +20,3 @@ configure_file(cynara.pc.in cynara.pc @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cynara.pc
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
-configure_file(cynara-compat.pc.in cynara-compat.pc @ONLY)
-
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cynara-compat.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
-foreach(item cynara-admin.pc
- cynara-agent.pc
- cynara-client-async.pc
- cynara-client.pc
- cynara-commons.pc
- cynara-creds-commons.pc
- cynara-creds-dbus.pc
- cynara-creds-gdbus.pc
- cynara-creds-self.pc
- cynara-creds-socket.pc
- cynara-monitor.pc
- cynara-plugin.pc
- cynara-session.pc)
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/link-to-cynara-compat.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
- RENAME ${item})
-endforeach(item)
-