aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2019-10-14 18:02:38 +0200
committerJose Bollo <jose.bollo@iot.bzh>2019-10-16 11:05:46 +0200
commitd927b8c4d931b3fa4c5744778976081e9218a838 (patch)
tree41a8403daf9d90caa46429d625da4ff92b51261c /src/CMakeLists.txt
parentf53a76ce91ab83c7345a104b57f148738101c58d (diff)
Implementation of agent protocol and tool
Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 300fd3d..0c1417d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -109,3 +109,11 @@ target_link_libraries(cynagoracli cynagora)
install(TARGETS cynagoracli
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
+###########################################
+# build and install cynagora-agent
+###########################################
+add_executable(cynagora-agent main-cynagora-agent.c expire.c)
+target_link_libraries(cynagora-agent cynagora)
+install(TARGETS cynagora-agent
+ RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
+