summaryrefslogtreecommitdiffstats
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-07-23 18:08:16 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-07-23 18:08:16 +0200
commit77474b9416830a83551453b3a857cc9ed6674267 (patch)
treedb3efc1c6dfc5e860d4bc94622df91dfab0cc08b /systemd/CMakeLists.txt
parent15011a8739849e703ced1baae2fd15e34650bd96 (diff)
Install agent socket for systemd
Change-Id: I838788b71908a287fe45c59ed51c20a3f8007a70 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index 3fde22f..9ea1f7e 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -21,12 +21,14 @@ set(SYSTEMD_UNIT_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/systemd/system"
CONFIGURE_FILE(cynara-admin.socket.in cynara-admin.socket @ONLY)
CONFIGURE_FILE(cynara-check.socket.in cynara-check.socket @ONLY)
+CONFIGURE_FILE(cynara-agent.socket.in cynara-agent.socket @ONLY)
INSTALL(FILES
${CMAKE_CURRENT_SOURCE_DIR}/cynara.service
${CMAKE_CURRENT_SOURCE_DIR}/cynara.target
${CMAKE_CURRENT_BINARY_DIR}/cynara-admin.socket
${CMAKE_CURRENT_BINARY_DIR}/cynara-check.socket
+ ${CMAKE_CURRENT_BINARY_DIR}/cynara-agent.socket
DESTINATION
${SYSTEMD_UNIT_DIR}
)