summaryrefslogtreecommitdiffstats
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-09-11 11:28:34 +0200
committerJose Bollo <jose.bollo@iot.bzh>2018-09-17 13:17:56 +0200
commit7ae3477d84ae13c5e9ef9bb1980a8f70f8b7e9bf (patch)
tree46c1ddda9a4dcc4782ceab8deb2f891ad3b0f2c8 /systemd/CMakeLists.txt
parent11654afcb5753a54a033db12e1ed4a19b3f7c86e (diff)
Make it work for AGL
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt32
1 files changed, 15 insertions, 17 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index f8116a2..3fde22f 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -1,25 +1,23 @@
-# Copyright (c) 2014-2016 Samsung Electronics Co., Ltd All Rights Reserved
+###########################################################################
+# Copyright (C) 2018 "IoT.bzh"
#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
+# author: José Bollo <jose.bollo@iot.bzh>
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-# @file CMakeLists.txt
-# @author Lukasz Wojciechowski <l.wojciechow@partner.samsung.com>
+# http://www.apache.org/licenses/LICENSE-2.0
#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
-SET(CYNARA_ADMIN_SOCKET_GROUP
- "security_fw"
- CACHE STRING
- "Group to apply on administrative sockets")
+set(SYSTEMD_UNIT_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/systemd/system"
+ CACHE PATH "Path to systemd system unit files")
CONFIGURE_FILE(cynara-admin.socket.in cynara-admin.socket @ONLY)
CONFIGURE_FILE(cynara-check.socket.in cynara-check.socket @ONLY)